OpenNMT

Opennmt-tf checkpoint to Ctranslate2

I recently started using ctranslate-2 but when i tried to convert the checkpoint it is giving me an error

raise TypeError(‘Expected binary or unicode string, got %r’ %
TypeError: Expected binary or unicode string, got None

I have the recent version of both Opennmt and ctranslate

Can you post the command line that you used and the complete error log?

Thank you for the quick reply,
commant line:ct2-opennmt-tf-converter --model_path indic-bert-v1 --output_dir ende_ctranslate2 --src_vocab indic-bert-v1/spiece.vocab --tgt_vocab indic-bert-v1/spiece.vocab --model_type TransformerBase

What’s the content of the directory indic-bert-v1? It seems it does not contain a checkpoint.

Alternatively, I would suggest converting your model via OpenNMT-tf. See the documentation.

It contains a checkpoint “tf_model.ckpt.data-00000-of-00001”. Anyway i have tried it with another model also i am getting the same error

Do i have to run the --export command on the final checkpoint? because retraining the entire model is pretty difficult

Looks like you are trying to convert this model:

But this model was not trained with OpenNMT-tf and so it cannot be converted to CTranslate2.

i have also tried it with another checkpoint of a model which i am currently trainig with opennmt-tf
i am getting the same error

Can you post the command line that you used for this model and the content of the model directory?

I have solved the problem.Thank you