I ran into problems getting started with OpenNMT on AWS

Hi everyone,

it is my first attempt to run OpenNMT. I don’t have a device that supports CUDA so I installed ami-8463e892 on AWS t2.micro. It is not the ami mentioned in the installation instruction, but it is the only one I found.

I installed nvidia-docker as mentioned in http://opennmt.net/OpenNMT/installation/ and tried to run the container like this:

ubuntu@ip-1-2-3-4:~$ sudo nvidia-docker run --rm nvidia/cuda nvidia-smi
nvidia-docker | 2017/06/13 16:11:53 Error: unsupported Docker version

The system:

ubuntu@ip-1-2-3-4:~$ dpkg -l | grep -i nvidia
ii  bbswitch-dkms                         0.8-3ubuntu1                               amd64        Interface for toggling the power on NVIDIA Optimus video cards
ii  libcuda1-375                          375.51-0ubuntu1                            amd64        NVIDIA CUDA runtime library
ii  nvidia-375                            375.51-0ubuntu1                            amd64        NVIDIA binary driver - version 375.51
ii  nvidia-375-dev                        375.51-0ubuntu1                            amd64        NVIDIA binary Xorg driver development files
ii  nvidia-docker                         1.0.0~rc.3-1                               amd64        NVIDIA Docker container tools
ii  nvidia-driver-local-repo-ubuntu1604   375.51-1                                   amd64        nvidia-driver-local repository configuration files
ii  nvidia-modprobe                       375.51-0ubuntu1                            amd64        Load the NVIDIA kernel driver and create device files
ii  nvidia-opencl-icd-375                 375.51-0ubuntu1                            amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                          0.8.2                                      amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                       375.51-0ubuntu1                            amd64        Tool for configuring the NVIDIA graphics driver

ubuntu@ip-1-2-3-4:~$ lspci | grep -i vga 
00:02.0 VGA compatible controller: Cirrus Logic GD 5446

Is something missing?

Thanks for any help and have a nice day!

Hi @ymmd,

The t2 instances don’t have any compute GPU. You’ll want a p2 instance for nvidia-docker to be of any use.


1 Like