OpenNMT Forum

Something Wrong when translating and also a similar error when training



File “/home/hong/PJTs/OpenNMT-py/onmt/inputters/datareader_base.py”, line 41, in _raise_missing_dep
"the following dependencies: " + ", ".join(missing_deps))

MissingDependencyException: Could not create reader. Be sure to install the following dependencies: PIL, torchvision, cv2

import PIL

import torchvision

import cv2

Do you have those dependencies installed?

yes, those were. and I run again today, the problem disappear.

I do this in server. it happened again …