Install Torch 7 with CUDA 9.1


(Panos Kanavos) #21

Hi @tel34,

The error shows that half operators are still in the play. Try to clean first and rerun it

./clean.sh
export TORCH_NVCC_FLAGS="-D__CUDA_NO_HALF_OPERATORS__"
./install.sh

(Terence Lewis) #22

Hi @panosk,
Yes, I’ve done that. The NVCC building now got to 11% and then failed as shown below. I’ve researched this but have not put my finger on what’s going wrong. It seems not to be retaining the export command. I’ve even tried putting it in bashrc.


(Panos Kanavos) #23

Hm, weird… Are you using bash? Try to run this and see:

echo $0

(Terence Lewis) #24

Yes, and I get -bash. I’ve tried it again since I sent the last message and it gets to 11% in the NVCC build and fails.


(Panos Kanavos) #25

Well, last things I can think of is try to source ~/.bashrc if you haven’t logged out/rebooted after you changed it, or put the export in front of install.sh in one line

TORCH_NVCC_FLAGS="-D__CUDA_NO_HALF_OPERATORS__" ./install.sh


(Terence Lewis) #26

Well, @panosk, I owe you a beer :-).
Putting the export in front of install.sh did the trick.
Hopefully tomorrow I can start some new trainings with my GTX 1080Ti.
And thanks to everyone else who offered suggestions!